
 

 

What's NEW in VCP 9.4.2.2 
IMPORTANT! - Licensing is NOT included in software shipments. See "How to get a license" 
below for details.    

May 2, 2024 

Dear VERICUT® User:  

Thank you for your continued investment in VERICUT, an important part of your NC 
programming and machining process!  

The VERICUT Composites Programming 9.4.2.2 is packed with new features making it more 
powerful and easier to use. This letter describes important changes in VERICUT Composites 
Programming 9.4.2.2. Please take a moment to review what's new and improved in this 
release.   
   

Maintenance and Licensing Information 

NOTE: This software requires VERICUT 9.4 licensing and Sentinel 9.8.1 License Server 
installation. 

 

To Get a License – use the link below to submit a License Request: 

http://www.cgtech.com/vericut_support/request-license/. 
 

Licensing is sent via Email only. 

 

VERICUT 9.4.2. runs on 64-bit Windows, and is supported on Windows 10 and 11 computers. 
 
Software maintenance keeps you on the cutting edge - CGTech provides update software 
to customers with current software maintenance. Your continued maintenance ensures 
that you have the most advanced verification technology available. If your maintenance 
has expired, please contact your CGTech representative 
(http://www.cgtech.com/about/contact-us/).  
  
Sincerely,   
Olivier Munaux   
CGTech VERICUT Composites Product Manager  

http://www.cgtech.com/vericut_support/request-license/
http://www.cgtech.com/about/contact-us/
http://www.cgtech.com/about/contact-us/
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VCP 9.4.2.2 
Problems Resolved in VCP 9.4.2.2 

An issue where the Centerline position slider breaks some VcPost functions has been resolved.  

An issue where less than full courses generated using the Centerline position slider causes poor 
tow selection when using Modify -> For each pick on a tow path… -> split a tow has been fixed. 
An issue preventing tows to be added to some courses generated using the Centerline position 
slider has been resolved. 
A problem causing Tow Balance to report incorrect lengths has been corrected. 

An issue causing laser inspection to only export every-other head path in some instances has 
been resolved. 
ATL laser inspection data now exports at the correct Z level – even when courses extend outside 
of the ply boundary. 
A problem causing missing ATL cut data after reseating courses has been resolved. 

An issue preventing Tow balancing from working correctly with less than full courses generated 
by the Centerline position slider has been resolved. 
An issue preventing a course from being removed and lingering as a “ghost” course has been 
resolved. 

 
 
 

VCP 9.4.2.1 
Problems Resolved in VCP 9.4.2.1 

An issue causing VCP to unexpectedly exit when modifying the position of a headpath relative 
to the course/tows has been fixed. 
An issue preventing Generate Courses None (<<) from removing all tows has been fixed. 

An issue preventing Laser Projection files to be generated on Contour courses has been 
resolved. 
An issue returning incorrect tow numbers to the Post Processor has been fixed. 

 
 
 
 
 



Release Notes  
  

3  
  

VCP 9.4.2 
Enhancements in VCP 9.4.2 
Added ability to adjust the size of head orientation vectors shown within the Roller Visualization, 
and Post cards in Preferences -> Colors -> Display Settings. 

 
 
 
Consolidated robot kinematic logic to a new Python class within core VCP, making post writing easier 
and more standardized. 
Robot Library JNI was updated to support rotisseries. 
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Problems Resolved in VCP 9.4.2 
An issue causing Lead-In length to be shortened when using a Boundary Inset has been 
resolved.  
Ply boundaries, Head paths, and Cutouts now use new logic to generate Laser Projection Data. 

An issue preventing courses from being generated on a thick part in some areas has been 
resolved. 
An issue preventing VCP from detecting all gaps during gap detection has been fixed. 

An error while editing an Option pin placed at the beginning or end of a link has been resolved. 

An issue preventing the editing of Option pins on a Contour course has been resolved. 

A problem where Minimum Length tows caused poor trimming on helical wraps has been fixed. 

An issue where ATL course width was returning incorrect values has been resolved. 

An issue causing duplicate cut data points in rare occasions has been resolved. 

A problem causing tow trim issues in Winding paths has been resolved. 

An issue preventing the Grader from working in all configurations has been fixed. 

 
 
 
 
 

VCP 9.4.1.1 
Problems Resolved in VCP 9.4.1.1 

An issue causing an execution interruption while laying only one side of odd number of tows 
has been resolved.  
An issue causing multiple option pins to be changed while modifying one has been resolved.  

An issue causing incorrect scrap display in some edge cases on wide tape after a trimming 
operation has been resolved. 

A rare case where point.width() returned an incorrect result has been resolved. 

ATL cut data filtering has been enhanced to eliminate the occurrence of overlapping cuts. 
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VCP 9.4.1 
Enhancements in VCP 9.4.1 
Added the ability to define which tows are active while laying tape in Setup -> Head. 

 
 
 
 
 
Added the ability to easily define which tows are being laid while generating courses in  
Generate -> Courses -> Layup Coverage. 
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Added a feature to allow for easier modification of Option Pin locations in Modify -> Option Pins. 

 
 
 
Added the ability to disable course-course tow trimming in Setup -> Layup -> Advanced Path 
Generation Settings -> Do not preform course-course trimming 

Added the ability to Hide/Show batch actions in Batch Manager ->   

Exposed the Robot API to the Python Post Processor for Angle <-> Matrix conversions. 

Added flexibility when dividing courses with ‘n’ tows into courses with ‘m’ tows in Modify -> Divide. 

Added a flag to File -> Form Surfaces to alert the user that an imported surface has been healed. 

Added the ability to set linking start point to the end of a course. Generate->Links->Start Point  

Refined head reversal logic for more clarity and control when linking. 

Added a batch mode to remove all links from a ply. 
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Problems Resolved in VCP 9.4.1 
Resolved an issue where ATL fiber compaction was not being displayed properly. 

Resolved an issue preventing single tows from being properly rendered. 

Fixed an issue preventing some STEP files from being imported. 

Added an error message when attempting to import unsupported CAD models. 

Fixed an issue preventing proper ATL course generation in some instances. 

Resolved an issue with Laser Inspection files when using ATL. 

Resolved an issue preventing “Insert pin every…” from working on ATL courses. 

Resolved an issue where head normals were not being calculated properly during lead in/out  

in rare circumstances. 

Fixed an issue causing poor trimming of wide tape to a boundary. 

Resolved an issue causing a crash while running the “Determine Stagger Point” batch action. 

Fixed an issue with overlapping cut geometry in ATL. 

 

 
 
 
 
 

VCP 9.4.0.4 
Enhancements in VCP 9.4.0.4 
Temporary visuals (Points, Curves) have been exposed in the Python API. 

A triangle was added to the mouse icon in Tools -> Axes -> Create new coordinate system to remind 
users of a hidden right-click menu. 
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Problems Resolved in VCP 9.4.0.4 
An issue sorting boundaries with long names in the Layup Coverage card has been resolved. 

An issue causing incorrect course angle generation in ATL when using a 0.0 Minimum course-
course gap has been resolved. 

An issue with incorrect Steering Radius analysis “heat” map coloring has been resolved. 

An issue preventing courses from being generated on a dome part has been resolved. 

An unexpected exit caused by generating ATL courses with more than 1 tow has been resolved. 

An issue causing missing surfaces when exporting ATL surfaces has been resolved. 

An issue causing unexpected results when extending ATL courses to full width has been resolved. 

An issue causing side cuts to be removed when breaking ATL packet to courses has been resolved. 

An issue causing unexpected results when cutting ATL courses to a boundary has been resolved. 

An issue preventing the Steering Radius measurement pin from being displayed has been resolved. 

An issue causing twisted surfaces when exporting ATL surfaces has been resolved. 

An issue causing incorrect Roll Center offset motion has been resolved. 

An issue preventing the Distance along course function to work in the Contour card has been 
resolved. 
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VCP 9.4.0.3 
Enhancements in VCP 9.4.0.3 
Users can now set the transparency of courses to allow boundaries and other geometry to show 
through. 

Start Points are now visible even when they coincide with an existing point. 

 
 
 
 

Problems Resolved in VCP 9.4.0.3 
Updating links no longer reverts head paths defined as links. 

ATL Option pins now correctly post on Lead-ins and Run-outs. 

An issue with ATL roller compaction visualization has been resolved. 

An issue with ATL Query to gap analysis has been resolved.  
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VCP 9.4.0.2 
Enhancements in VCP 9.4.0.2 
Updated documentation for Maximum on-form traverse regarding wide tape. 

 

 
 
 
 

Problems Resolved in VCP 9.4.0.2 
An issue where VCP was missing some collisions has been resolved. 

A bug preventing islands to render properly when using ATL has been resolved. 

An issue when restoring all original cuts has been resolved. 

Issues with ‘create on-part scrap cuts’ have been resolved. 

Issues with ‘remove on-part scrap cuts’ have been resolved. 
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VCP 9.4.0.1 
Enhancements in VCP 9.4.0.1 
Updated VCP training sessions for version 9.4. 

Updated VCS training sessions for version 9.4. 

 

 
 
 
 

Problems Resolved in VCP 9.4.0.1 
An issue with poor trimming while using ‘cut all courses to the selected boundary’ has been fixed. 

An issue causing crashes when using ‘cut all courses to the selected boundary’ has been fixed. 

An issue with ATL gap analysis has been fixed. 

An issue causing poor trimming when exporting CATIA files in batch mode has been resolved. 

An issue which generated an incorrect error message when using ‘make full width’ has been fixed. 

Issues with ‘create on-part scrap cuts’ have been resolved. 

Issues with ‘remove on-part scrap cuts’ have been resolved. 
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VCP 9.4 
Enhancements in VCP 9.4 
Added a new Curve Card to allow users to display and modify curves. 

 
 

Added the ability for users to flip the direction of curves. 
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Added the ability for users to smooth curves. 

 
 

Added the ability to generate Stagger Reference Curves from manually selected curve. 
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Added the ability to Expand/Collapse all options in the VCP Laminate Manager tree. 

 
 

Added the ability to set default Analysis settings in profiles. 
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Added the ability to import CATIA 3DEXPERIENCE Composite files (requires additional license). 

Features: 
• Read CATIA CPD 3DXML file output up to version R2022X 
• Read native programming CAD surfaces 
• Read native tooling CAD surfaces 
• Read Laminate stacking tree structure 
• Read Ply boundaries 
• Read Start points 
• Read Fiber direction 
• Read Material density  

 

Enhanced the import of SOLIDWORKS files. 

Added a Jython API for our robot library. 

Added the ability to set the Material Bulk Factor as a percentage in Material Settings. 

VCP now auto-populates file extensions when saving parts, surfaces, posts, etc. 

Added the ability to remove all options pins on a selected course. 

The user may now drag and drop post processors onto the Laminate Manager. 

VCP now automatically checks for updates upon launch if desired. 

VCP now allows the user to display ATL cuts in Preview Window relative to selected CSYS. 

VCP now highlights the active or selected CSYS for easy reference. 

Added the ability to query batch reports with the Python API 

Exposed File->Import CAD Geometry to the Python API 

Exposed File->Read Template to the Python API 

Roll Center offset has been enhanced for use in thinner parts. 
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Problems Resolved in VCP 9.4 
An issue preventing Modify Pin Location from working with ATL has been fixed. 

An issue causing ‘object has no attribute’ error while loading some post processors has been fixed. 

An unexpected program exit caused when Minimum form radius < 1mm has been fixed. 

An issue preventing courses from being generated in some instances has been resolved. 

An issue causing courses to extend pass surface edges causing undesired twists has been 
resolved. 

An issue causing barrel wraps to fail has been resolved. 

An issue preventing Roller Diameter from updating in the Roller Visualization card has been fixed. 

An issue causing a “TypeError“ error message while running VCP in headless mode has been fixed. 

An issue causing incorrect A/B course coloring has been resolved. 

An issue preventing the course centerline from trimming in some situations has been resolved. 

An issue causing “Delete and Add” buttons from being visible when adding New Advanced 
Rosette has been fixed. 

An issue causing an unexpected program exit while using Generate VCS Project has been fixed. 

An issue causing “Delete and Add” buttons from being visible when adding New Advanced 
Rosette has been fixed. 

An issue causing an unexpected program exit when generating courses using Splice Cut lines has been 
fixed. 

An issue with ATL on part Scrap Cuts has been fixed. 

An issue with ATL Make Full Width has been fixed. 

An issue with Gap and Lap reporting in ATL has been fixed. 
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